Problem of graphics card after SAMSON installation on Ubuntu 18.04 (Intel processors)



  • @Robert

    I think, it might be connected to the Wayland display being used instead of Xorg (see: https://forum.samson-connect.net/topic/37/installing-or-running-samson-on-ubuntu-17-04-and-later-versions). I would suggest you to try installing Xorg and disabling Wayland display.

    See, e.g.: https://linuxconfig.org/how-to-disable-wayland-and-enable-xorg-display-server-on-ubuntu-18-04-bionic-beaver-linux



  • Thank you Dmitryi, I had not seen that trick of disabling Wayland display. I tried and reboot but nothing changed sor SAMSON or VMD display. I don't know how to be sure that Xorg display is used .. When I type "Xorg" (or "Xorg -version") in the terminal I get :

    /usr/lib/xorg/Xorg.wrap: Only console users are allowed to run the X server

    However when I type "sudo Xorg -version", I get :

    X.Org X Server 1.19.6
    Release Date: 2017-12-20
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 4.4.0-138-generic x86_64 Ubuntu
    Current Operating System: Linux pl365-pro 4.15.0-47-generic #50-Ubuntu SMP Wed Mar 13 10:44:52 UTC 2019 x86_64
    Kernel command line: BOOT_IMAGE=/vmlinuz-4.15.0-47-generic root=/dev/mapper/VGsys-root ro
    Build Date: 25 October 2018 04:11:27PM
    xorg-server 2:1.19.6-1ubuntu4.2 (For technical support please see http://www.ubuntu.com/support)
    Current version of pixman: 0.34.0
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.

    I don't know if it is normal, but I don't have any xorg.conf file in /etc/X11/ (as should be the case according to https://doc.ubuntu-fr.org/xorg). Maybe I should create and edit one such file in that precise directory ?

    When I type "locate xorg.conf", I get :

    /usr/share/X11/xorg.conf.d
    /usr/share/X11/xorg.conf.d/10-amdgpu.conf
    /usr/share/X11/xorg.conf.d/10-quirks.conf
    /usr/share/X11/xorg.conf.d/10-radeon.conf
    /usr/share/X11/xorg.conf.d/40-libinput.conf
    /usr/share/X11/xorg.conf.d/70-wacom.conf
    /usr/share/doc/xserver-xorg-video-intel/xorg.conf
    /usr/share/man/man5/xorg.conf.5.gz
    /usr/share/man/man5/xorg.conf.d.5.gz

    Maybe I should type "sudo dpkg-reconfigure -phigh xserver-xorg" to reconfigure automatically Xorg, as suggested in ttps://doc.ubuntu-fr.org/xorg ?

    Thank you.
    Robert



  • Could you, please, check whether Wayland or X11 display is used, e.g. (please, check for the proper way on Ubuntu):

    echo $XDG_SESSION_TYPE
    

    or

    cat /etc/X11/default-display-manager
    

    or

    loginctl show-session $(loginctl | grep $(whoami) | awk '{print $1}') -p Type
    

    If your system is using Xorg and you still experience problems with OpenGL you may try switching to the lightdm display manager (please, check for Ubuntu 18.04):

    sudo dpkg-reconfigure lightdm
    sudo apt-get install lightdm
    


  • Thank you Dmitryi.

    cat /etc/X11/default-display-manager
    gives me :

    /usr/sbin/gdm3

    echo $XDG_SESSION_TYPE
    gives me :
    x11

    loginctl show-session 2 -p Type

    gives me :

    Type=x11

    So I think x11 is turned on and not Wayland, so it seems OK.

    I then installed lightdm and replaced gdm3 by lightdm as a display manager, thus :

    cat /etc/X11/default-display-manager

    gives me now :

    /usr/sbin/lightdm

    I tried launching SAMSON but nothing changed, maybe I have to reboot and re-try..
    Thanks,
    Robert



  • @robert
    Yes, could you, please, try rebooting your system.



  • Hi Dmitryi, thanks, I tried rebooting, and having the new lightdm display instead of gdm3, but it didn't solve my problem for SAMSON nor for VMD...



  • @Robert
    Ok. I will try to read more on your issue and will come back to you once I have other ideas. If you solve the problem, could you, please, post the solution here. Thanks!



  • Thanks a lot Dmitryi. I will keep looking for a solution also on my side.
    I also asked for help of the support team at INRIA, so I let you know of course if I solve the problem. Best regards



  • Hello Dmitriy, hope you are doing well, I solved my problem for VMD, it was my bad, I had installed the text mode version (I didn't realize I was doing such a mistake ...). The problem for SAMSON was thus completely decorrelated from that of VMD.
    For SAMSON, the problem seems related to Ubuntu 18.04 Bionic and Intel i7 8th generation processors. It seems not to suffice that they support OpenGL 3.2. Another person in my team has almost the same computer , installed SAMSON and had the same graphics problem. When he activated his NVIDIA card, SAMSON worked (disgrafully, I don't have a NVIDIA card so I can't use this trick).

    Maybe it can be due to the libraries SAMSON appeals when it was built, maybe it asks for more than available to these new INTEL processors ? Or it is a specific problem related to Ubuntu 18.04 Bionic with such INTEL processors ... ?
    Best regards,
    Robert



  • Hello @Robert ,
    Thanks to your feedback, we have fixed the issue in SAMSON when using Intel integrated graphics processor. You can try installing SAMSON.


Log in to reply
 















Web
Analytics

Looks like your connection to SAMSON Connect - Forum was lost, please wait while we try to reconnect.