Build a Debug mode on linux

  • yes it was the kits, there was no autodetected ones.

  • Hello,

    I am now stuck with the launching of SAMSON-Debug. the launchind fails and says:
    This application failed to start because it could not find or load the Qt platform plugin "xcb"in "".
    Reinstalling the application may fix this problem.

    I tried to reinstall, not changing anything...


  • Dear @Laëtitia

    Do you try to launch with SAMSON Element Samples from github? If so, then in the root CMakeLists.txt you need to disable PyBindTutorial (just comment ADD_SUBDIRECTORY( PyBindTutorial )).

  • euh no, I just tried to launch in NANO-D/SDK/0.7.0/SAMSON-Debug/Binaries to have a look at the "new" element I created (the empty one I had problem displaying and compiling before with Qt)

  • @Laëtitia

    Have you provided a path to your Qt installation in the script for SAMSON-Debug?

    It should be smth like this: export LD_LIBRARY_PATH=/home/YourUser/Qt/Qt5.9.3/5.9.3/gcc_64/lib:$script_dir:$LD_LIBRARY_PATH

  • yes, I did
    export LD_LIBRARY_PATH=$script_dir:/home/bomble/Qt5.9.3/5.9.3/gcc_64/lib/:$LD_LIBRARY_PATH

  • Does SAMSON launch in Release mode?

    Could you, please, try adding into the script for SAMSON-Debug the a path to Qt platforms (/home/bomble/Qt5.9.3/5.9.3/gcc_64/plugins/platforms) to the LD_LIBRARY_PATH environment variable:
    which should provide a path to platforms ("xcb" including).

    Do you have any Python installed with PyQt5 and their paths set into PATH or LD_LIBRARY_PATH ? The platforms and Qt libs from Python installation may interfere.

  • Hello,

    Yes Samson launch in Release mode.
    Adding /home/bomble/Qt5.9.3/5.9.3/gcc_64/plugins/platforms path does not change anything (even if is indeed there!).
    export LD_LIBRARY_PATH=$script_dir:/home/bomble/Qt5.9.3/5.9.3/gcc_64/lib/:/home/bomble/Qt5.9.3/5.9.3/gcc_64/plugins/platforms/:$LD_LIBRARY_PATH

    I don't have PyQt5 installed at all.

  • if after setting the path I ldd the exe, I have only one lib with xcb in it called: => /usr/lib/x86_64-linux-gnu/ (0x00007f820fc81000)
    it's not calling for qxcb.
    Maybe I should installe another version of

  • @Laëtitia

    Could you, please, try making the following symbolic links in the SAMSON-Debug/Binaries folder :

    cd ~/NANO-D/SDK/0.7.0/SAMSON-Debug/Binaries
    ln -s ~/Qt5.9.3/5.9.3/gcc_64/plugins/platforms/ ./platforms
    ln -s ~/Qt5.9.3/5.9.3/gcc_64/plugins/xcbglintegrations/ ./xcbglintegrations

    If the symbolic links won't make it work, could you, please, try copying these folders from the Qt installation into the SAMSON-Debug/Binaries folder.

  • the symbolic links stuff worked! thanks a lot, but I don't understand why it works now, could you explain me?

  • @Laëtitia

    Great! Sorry for this issue!

    It is due to Qt debug libraries not being shipped together with SAMSON-Debug because they are too heavy. That's why you need to install Qt and apart from providing a path to Qt libraries themselves it is sometimes necessary to provide a path to the plugins folder (Qt5.9.3/5.9.3/gcc_64/plugins, subfolders platforms and xcbglintegrations in particular).

    What can also be done instead of creating symbolic links is to provide these paths in your ~/.bashrc file (this works for me on Ubuntu)

    export QT5_CMAKE_INCLUDE_DIR=$QT_PATH/gcc_64/lib/cmake/
    export QT5_PLATFORM_LIBRARY_PATH=$QT_PATH/gcc_64/plugins/platforms/

  • ok I see.
    Now I can start playing!

    Thanks for help and patience.

  • Good luck @Laëtitia !
    You can check for some SAMSON Elements Samples. We will be adding more soon.

    Feel free to ask questions!

Log in to reply

Looks like your connection to SAMSON Connect - Forum was lost, please wait while we try to reconnect.