Build a Debug mode on linux

  • Hello,
    I am learning how to developp on SAMSON on my ubuntu station.
    I am following step by step the tutorial there:
    and I would like more explanation on that part:
    "Provide a boolean variable named DEBUG and set its value to TRUE (ON) for the Debug build and to FALSE (OFF) for the Release build. If not present, provide a string variable named CMAKE_BUILD_TYPE and set its value to Debug for the Debug build or to Release for the Release build."
    Should I modify the Makefile directly or the cmake call?


  • ok, I am continuing my reading and it's look like I should do this addition directly in Qtcreator. Right?

  • Dear @Laëtitia ,

    Yes, this was a brief description in the beginning of the tutorial of steps which are necessary to do in an IDE of your choice. If you are using QtCreator, you should specify these variables in the Project settings.


  • thanks for your answer.
    Indeed I can specify easily add seetings in Qt. That part I get now.
    What is worying me is that when I open my project I don't have the MyElement cpp files opened, just the CMakeLists.txt is there. Please see attached a screenshot with on the left what I have and on the right what is in the tutorial.
    0_1543502530367_Capture du 2018-11-29 15-40-18.png

  • Have you specified the SAMSON_SDK_PATH in the Project settings? It should be set to your SAMSON SDK installation, e.g.: /home/user/NANO-D/SDK/0.7.0
    After setting it, press on the "Apply Configuration Changes" button.

  • yes I did and it find all samson things but it's the MyElement cpp files that it's not finding.

  • If you properly specified the SAMSON_SDK_PATH, and you still cannot see files in the project that might be due to CMake Generator settings of the chosen Kit in QtCreator during the "Configure Project" step.

    To check with different CMake Generator settings got to Projects -> Manage Kits and choose the Kit you are using. You may try to modify the CMake generator settings, e.g. to the ones shown below, but be aware that they depend on what packages you have installed.



    You can read more on setting Kits in QtCreator here:

  • Usually, if the Kit in QtCreator has some non-valid settings (e.g., CMake generator), it will be shown with a warning sign as for the last Kit on the picture below:

  • Thanks for your response, and sorry for the late replay.
    I now see the problem, or at least one problem, I have no autodetect kit and the other one seems broken so maybe it's my qt5.9 that is not as it should be?

  • 0_1543916823864_Capture du 2018-12-04 10-46-24.png

  • Usually, QtCreator should automatically detect/create the Kit for you, but it depends on the order of installation, e.g. if QtCreator you are using is installed before the Qt your want to use. You may try to use the "Desktop" one and if you still experience the problem, you may try to modify "CMake generator" in the Kit preferences (you do not need to create project from the scratch, just go to "Projects -> Manage kits ..." and modify the Kit you are using - try setting different "Generator" and "Extra generator").

    To determine, whether this problem is due to QtCreator (Kits), you may try creating any project in QtCreator itself (e.g., Application Console Project) and see check if it shows you source and header files.

  • ok I'll try, it's true I have another version installed that I used usually, I installed 5.9 specifiquelly for samson. I'll try

  • You also need to have CMake installed with a version at least 2.8.9.

    You may try to set the next generators in the "CMake generator" for your Kit: Unix Makefiles, Ninja (for that you need to have the "ninja-build" package installed).
    As an "Extra generator", I have CodeBlocks set, but it is dependant on your system.

  • oh it's compiling fine now!

  • Great! Congratulations!
    What was the problem? The generators in the Kit? If so which one did you set?

  • You can find more SAMSON Developer tutorials and we will be adding more source code soon on github: For example, you may check the AtomShaker tutorial.

  • yes it was the kits, there was no autodetected ones.

  • Hello,

    I am now stuck with the launching of SAMSON-Debug. the launchind fails and says:
    This application failed to start because it could not find or load the Qt platform plugin "xcb"in "".
    Reinstalling the application may fix this problem.

    I tried to reinstall, not changing anything...


  • Dear @Laëtitia

    Do you try to launch with SAMSON Element Samples from github? If so, then in the root CMakeLists.txt you need to disable PyBindTutorial (just comment ADD_SUBDIRECTORY( PyBindTutorial )).

  • euh no, I just tried to launch in NANO-D/SDK/0.7.0/SAMSON-Debug/Binaries to have a look at the "new" element I created (the empty one I had problem displaying and compiling before with Qt)

Log in to reply

Looks like your connection to SAMSON Connect - Forum was lost, please wait while we try to reconnect.