SAMSON crashes while opening pdb files



  • I found this on SAMSON Documentation webpage (https://documentation.samson-connect.net/users/latest/user_guide_getting_started.html):
    "Requirements
    For running SAMSON, a 64-bit operating system and a graphics card supporting OpenGL 3.2 are required. Intel graphics cards may currently cause issues. For NVIDIA and AMD graphics cards an appropriate driver with an OpenGL support should be installed."
    Should I install this driver? I have a higher version of OpenGL (6.14.10.9833). I am confused (AMD is the manufacturer of my graphic card).



  • Ok thanks. Maybe it is possible to upgrade to the latest version of your graphics card driver? Is it possible to deactive most rendering options in the preferences?

    • No ambient occlusion, no depth-of-field, no fog, no silhouettes, no shadows
    • In Selection: 0% opacities
    • Anti-aliasing: multisampling factor to 1, disable FXAA

    Please let me know.
    Thanks,
    S.



  • Dear @Radek

    The version 6.14.10.9833 you are referring to is no the version of OpenGL but it is the version of your ATI OpenGL driver. Please, check whether your driver has OpenGL 3.2 or higher. And try updating your driver if possible.

    As I can see, your GPU should support OpenGL 3.3 but I am not sure about your driver.



  • Dear @DmitriyMarin

    I am sorry, I have no idea how to check OpenGL. I thougt the info about this is within the application controlling the graphic card. If not - I do not know how to find it.



  • Dear @Admin
    I checked my settings and everything was set as you suggested. Usually I try to use as simple graphics as possible. I am affraid my graphic card is not compatible with SAMSON. I have the most recent driver of my graphic card.



  • Generally I am sorry for the basic questions, but I am the biologist, not the IT specialist.



  • @Radoslaw

    To check on Windows the OpenGL support of your GPU, you can, for example, install OpenGL Extensions Viewer. It should show you what version of OpenGL does your GPU support and, possibly, the version provided with your current driver.

    If you have the most recent driver for your ATI Mobility Radeon 550v GPU, then, I think, it should support OpenGL 3.3, since it is this version which is supported by your GPU.



  • Thank you. Within the info about my graphic card driver it is specified that it supports OpenGL 3.3. Anyway I cannot use SAMSON on my computer. For some reasons it causes the crashes of my graphic card. Thank you for your support, but I am unable to solve the problem. I use different similar programs without any problems (Auto Dock, Chimera, PyMOL etc.).



  • I have just found out that Chimera also needs OpenGL to work - and it works properly. So I do not know the reason of the problem.



  • Hi @Radoslaw, are there 3D settings in your ATI driver that you could change? (e.g. do you have Catalyst Control Center?). Also, do you have only one graphics card (ATI), or also an Intel one?



  • Dear @Radoslaw ,
    We have fixed an issue in SAMSON which was causing a problem with OpenGL context on Intel integrated graphics processors. We hope it might as well resolve the issue you had and we would be grateful if you could try re-installing SAMSON to check whether it fixes it.


Log in to reply
 

Looks like your connection to SAMSON Connect - Forum was lost, please wait while we try to reconnect.