Installing or running SAMSON on Ubuntu 17.04 and later versions



  • Hi,
    Sorry for delay.After installing mesa also I'm getting same error.Please give some suggestions to avoid this issues.
    Thank in advance
    Subhajit



  • Please, post the output of the following command:

    glxinfo | grep OpenGL
    


  • I'm getting following
    OpenGL vendor string: Intel Open Source Technology Center
    OpenGL renderer string: Mesa DRI Intel(R) Haswell Desktop
    OpenGL core profile version string: 3.3 (Core Profile) Mesa 17.2.8
    OpenGL core profile shading language version string: 3.30
    OpenGL core profile context flags: (none)
    OpenGL core profile profile mask: core profile
    OpenGL core profile extensions:
    OpenGL version string: 3.0 Mesa 17.2.8
    OpenGL shading language version string: 1.30
    OpenGL context flags: (none)
    OpenGL extensions:
    OpenGL ES profile version string: OpenGL ES 3.0 Mesa 17.2.8
    OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
    OpenGL ES profile extensions:



  • Could you please run the following command in the terminal and post it here:

    locate libOpenGL.so
    

    If you see in the result, for example, /usr/lib/x86_64-linux-gnu/libOpenGL.so but no libOpenGL.so.0, you will need to create a symlink.



  • Hi,
    Thank you for your reply.Could you please tell me how will I create a symlink.



  • Does the command locate libOpenGL.so show you libOpenGL.so or not?
    The symlink can be created in the terminal as follows:

    ln -s target linkname
    


  • After giving command 'locate libOpenGL.so' i'm not getting any output.



  • @Subhajig

    Could you, please, double-check whether libgl1-mesa-dev is installed:

    sudo apt-get install build-essential mesa-utils libgl1-mesa-dev
    

    Please, check the troubleshooting section of the SAMSON Installation guide.
    You can do a symlink to the libQt5OpenGL.so shipped together with SAMSON:

    ln -s $HOME/NANO-D/SAMSON/0.7.0/Binaries/SAMSONQtLibs/libQt5OpenGL.so $HOME/NANO-D/SAMSON/0.7.0/Binaries/SAMSONQtLibs/libOpenGL.so.0
    

    or you can install compiz and create symlink to its OpenGL:

    sudo apt-get install compiz-dev
    sudo ln -s /usr/lib/x86_64-linux-gnu/compiz/libopengl.so $HOME/NANO-D/SAMSON/0.7.0/Binaries/SAMSONQtLibs/libOpenGL.so.0
    


  • Hi
    Thank you for your help.It worked fine.But Now I have another problem.In SAMSON installer tab I 'm not able to write samson key after giving my email address,
    So installation is not being started.



  • Installation is done.


Log in to reply
 















Web
Analytics

Looks like your connection to SAMSON Connect - Forum was lost, please wait while we try to reconnect.