ElementGenerator not working



  • Hi,

    I have been developing under SAMSON 0.5.0 and 0.6.0 a plugin. Now I'm trying to make it compatible with SAMSON 0.7.0.

    After installing both SAMSON and the SDK, I get an error when I try to run ElementGenerator: SBGLog.dll, SBDType.dll, SBCLog.dll and SBCContainer.dll can't be found.

    The only difference in the installation that I can see with respect to previous versions, is that the Binaries folder now just contains the executables.

    Is there anyone else having this problem or knows how to solve it?

    Thank you and best regards,

    Elisa



  • Hi Elisa,starting with 0.7.0, the Element Generator is now a SAMSON Element that you can find at https://samson-connect.net/app/main?key=element&uuid=b0d9900c-b058-e7fa-4c31-d85f18b9c4e2.

    Best,

    S.



  • Ah, thank you!! Is there a Changelog I can take a look at?

    Regards,

    Elisa



  • Nope sorry, and we're still updating the SDK documentation. Please don't hesitate if you're having some issues porting to 0.7.0.



  • In case someone else is in the same situation. I just finished porting our plugin to 0.7.0 and the only changes I had to make were in SAMSON::getProxy (the arguments have changed), and the call functions of the proxies (arguments of SBValue type used to be pointers, now they are passed by reference).

    We have still to test it to make sure all functionality is working, but so far it seems that was it.

    Regards,

    Elisa


Log in to reply
 

Looks like your connection to SAMSON Connect - Forum was lost, please wait while we try to reconnect.