Missing SBCLibraryConfig.cmake in SDK 0.11.0



  • I have installed SAMSON 0.11.0 and SDK 0.11.0. Although there was a CMake warning about missing SBCLibrary, the compilation finished without any errors (SAMSON_SDK_PATH was correctly set). I checked both KEY_DEVELOPER_DATA_PATH in KEY_SOFTWARE_INFO and SDKDeveloperDefinitions.cmake, they all are fine. SAMSON-SDK was executed but it didn't load the new element.

    CMake Warning at /home/lqdong/OneAngstrom/SDK/0.11.0/cmake/FindSAMSONSDK.cmake:77 (FIND_PACKAGE):
      By not providing "FindSBCLibrary.cmake" in CMAKE_MODULE_PATH this project
      has asked CMake to find a package configuration file provided by
      "SBCLibrary", but CMake did not find one.
    
      Could not find a package configuration file provided by "SBCLibrary" with
      any of the following names:
    
        SBCLibraryConfig.cmake
        sbclibrary-config.cmake
    

    When SAMSON-debug ran, there was no line for loading my UUID element. Other elements come with xml information file so I tried to define it my self. This time, SAMSON-debug console reported:

    =============== SBGPath summary infos ================
    
    ===================================================================
    ===================================================================
    4596610A-C0D5-7C96-9058-E9FC3D2FDB32.so Errors
    ------------------------------------------------------------------
    > Cannot load library
          Sorry I cannot help you
    ===================================================================```
    
    

    This means SAMSON-debug tried to load developer element at the correct PATH (if this element has xml). I suspect that the problem was caused by missing SBCLibrary. I couldn't find SBCLibraryConfig.cmake in SDK directory. Could anybody help me with this?

    Best regards,

    Dong.



  • Dear sir,

    Can you please execute theses command and provide the output

    export LD_LIBRARY_PATH=[SAMSON-DEBUG-BINARIES]:[QT_LIBRARY_PATH]:$LD_LIBRARY_PATH
    cd [PATH of KEY_DEVELOPER_DATA_PATH]
    ldd 4596610A-C0D5-7C96-9058-E9FC3D2FDB32.so

    Jocelyn



  • Thank you so much for helping me. I tried to link exactly Qt5.12.5 (my own version is 5.14.1) so it works now. Again, thank you so much.

    Best regards,

    Dong.


Log in to reply
 

Looks like your connection to SAMSON Connect - Forum was lost, please wait while we try to reconnect.